您的位置:首页 > 其它

POJ 1789 Truck History 【最小生成树&&Kruskal】

2015-08-12 09:37 411 查看
Truck History
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 21614Accepted: 8399
Description
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string
of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from
the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase
letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.



以下是别人的翻译:(原文链接:/article/1968878.html)

题意大概是这样的:用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号“衍生”出来,代价是这两个编号之间相应的distance,现在要找出一个“衍生”方案,使得总代价最小,也就是distance之和最小。
例如有如下4个编号:
aaaaaaa

baaaaaa

abaaaaa

aabaaaa

显然的,第二,第三和第四编号分别从第一编号衍生出来的代价最小,因为第二,第三和第四编号分别与第一编号只有一个字母是不同的,相应的distance都是1,加起来是3。也就是最小代价为3。
问题可以转化为最小代价生成树的问题。因为每两个结点之间都有路径,所以是完全图。
此题的关键是将问题转化为最小生成树的问题。每一个编号为图的一个顶点,顶点与顶点间的编号差即为这条边的权值,题目所要的就是我们求出最小生成树来。这里我用prim算法来求最小生成树。


值得注意的是,存图可以考虑用二维数组,其他的都好弄。由于已经定义了每个编号为七个字符,所以一个一个输入。



#include<stdio.h>
#include<algorithm>
#define maxn 2020
using namespace std;

char str[maxn][8];
int per[maxn], n, k;

struct node{
	int u, v, w;
};
node edge[maxn * maxn];

int cmp(node a, node b){
	return a.w < b.w;
}

void init(){
	int i;
	for(i = 0; i < n; ++i)
	per[i] = i;
}

int find(int x){
	int r = x;
	while(per[r] != r)
	r = per[r];
	per[x] = r;
	return r;
}

void kruskal(){
	init();
	sort(edge, edge + k, cmp);
	int fx, fy, sum = 0, i;
	for(i = 0; i < k; ++i){
		fx = find(edge[i].u);
		fy = find(edge[i].v);
		if(fx != fy){
			per[fx] = fy;
			sum += edge[i].w;
		}
	}
	printf("The highest possible quality is 1/%d.\n",sum);
}

int main(){
	while(~scanf("%d",&n), n){
		int i, j, c, t;
		for(i = 0; i < n; ++i){
			for(j = 0; j < 8; ++j){
				scanf("%c",&str[i][j]);
			}
		}
		k = 0;
		for(i = 0; i < n - 1; ++i){
			for(j = i + 1; j < n; ++j){
				for(c = 0, t = 0; c < 8; c++){
					if(str[i][c] != str[j][c]){
						t++;
					}
				}
				edge[k].u = i;
				edge[k].v = j;
				edge[k].w = t;
				k++;
			}
		}
		kruskal();
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: