您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 1 1011 KazaQ's Socks

2017-07-25 19:58 435 查看

KazaQ's Socks

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0
[/align]

[align=left]Problem Description[/align]
KazaQ wears socks everyday.

At the beginning, he has n
pairs of socks numbered from 1
to n
in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are
n−1
pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on thek-th
day.
 

[align=left]Input[/align]
The input consists of multiple test cases. (about2000)

For each case, there is a line contains two numbers
n,k(2≤n≤109,1≤k≤1018).
 

[align=left]Output[/align]
For each test case, output "Case #x:y"
in one line (without quotes), where x
indicates the case number starting from 1
and y
denotes the answer of corresponding case.
 

[align=left]Sample Input[/align]

3 7
3 6
4 9

 

[align=left]Sample Output[/align]

Case #1: 3
Case #2: 1
Case #3: 2

题意是说KazaQ有n双袜子,标号1到n放在柜子里,每天早上起床穿袜子选标号最小的一双。
然后晚上回来将穿过的扔到篮子里。当篮子里的袜子数量为n-1的时候,就把这些袜子洗一下,
第二天晚上再放回柜子里。问KazaQ在第K天穿的是哪一个标号的袜子

n=3时
n k ans
3 1 1
3 2 2
3 3 3
3 4 1
3 5 2
3 6 1
3 7 3
3 8 1
3 9 2
3 10 1
3 11 3
。。。。。。

n=4时
n k ans
4 1 1
4 2 2
4 3 3
3 4 4
4 5 1
4 6 2
4 7 3
4 8 1
4 9 2
4 10 4
4 11 1
4 12 2
4 13 3
4 14 1
4 15 2
4 16 4
。。。。。。

观察规律:前n天,第i天袜子是i,之后,天数-n,即i-n, n-1为周期,
第i天,(i-n)%(n-1) 不为0, 袜子为(i-n)%(n-1),
否则, (i-n)/(n-1)为奇数 袜子n-1
(i-n)/(n-1)为偶数,袜子为n

#include <iostream>
using namespace std;
typedef long long int ll;

int main()
{
ll n, k;
int gg = 1;
while (cin >> n >> k)
{
cout << "Case #" << gg << ": ";
gg++;
if (k <= n)
{
cout << k << endl;
continue;
}
else
{
ll m = (k - n) % (n - 1);
if (m == 0)
{
m = n;
}
ll rare = (k - n) / (n - 1);
if (m < n - 1)
{
cout << m << endl;
}
else
{
if (rare % 2)
{
cout << n - 1 << endl;
}
else
{
cout << n << endl;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 多校训练 模拟
相关文章推荐