您的位置:首页 > 其它

poj2352--Stars--线段树&树状数组

2013-08-10 12:48 489 查看
Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26892 Accepted: 11746
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source

Ural Collegiate Programming Contest 1999

线段树或者树状数组的简单题,拿来练手用~

看注释很容易理解程序,以下是线段树版本:

//线段树版本
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <cstdlib>
using namespace std;
const int apex=0x7FFFFFFF;
const int fundus=0;
const int maxnum=32010;
const int _max=15010;
typedef struct
{
int l,r;
int number;
}Node;
Node star[3*maxnum];
int res[_max];
int star_num;
void make_tree(int l,int r,int root)//建树
{
star[root].l=l;
star[root].r=r;
star[root].number=0;
if(l==r)
return;
else
{
int mid=(star[root].l+star[root].r)>>1;
make_tree(l,mid,root<<1);
make_tree(mid+1,r,root<<1|1);
}
}
void count_star(int l,int r,int root)//数区间内星星数量
{
if(star[root].l==l&&star[root].r==r)
{
star_num+=star[root].number;
}
else
{
int mid=(star[root].l+star[root].r)>>1;
if(l>mid)
{
count_star(l,r,root<<1|1);
}
else if(r<=mid)
{
count_star(l,r,root<<1);
}
else
{
count_star(l,mid,root<<1);
count_star(mid+1,r,root<<1|1);
}
}
return;
}
void insert_star(int l,int r,int root,int x)//在区间中插入星星
{
int mid=(star[root].l+star[root].r)>>1;
if(x>=l&&x<=r)
{
star[root].number++;
}
if(l==r) return;
if(x<=mid)
{
insert_star(l,mid,root<<1,x);
}
else
{
insert_star(mid+1,r,root<<1|1,x);
}
}
int main()
{
make_tree(0,32000,1);
int n;
cin>>n;
for(int i=0;i<n;i++)
{
star_num=0;
int x,y;
scanf("%d%d",&x,&y);
count_star(0,x,1);
++res[star_num];
insert_star(0,32000,1,x);
}
for(int i=0;i<n;i++)
printf("%d\n",res[i]);
return 0;
}


以下是树状数组版本,空间占用小,跑的也快~~啦啦

//树状数组版本
#include <iostream>
#include <cstdio>
using namespace std;
const int _maxnum=32010;
const int _max=15010;
int star_level[_max];
int star_num[_maxnum];
int lowbit(int t)
{
return t&(-t);
}
int	sum(int n)
{
int temp=0;
while(n>0)
{
temp+=star_num
;
n=n-lowbit(n);
}
return temp;
}
void change(int position,int change_num)
{
while(position<=_maxnum)
{
star_num[position]+=change_num;
position=position+lowbit(position);
}
}
int main()
{
int n;
cin>>n;
for(int i=1;i<=n;i++)
{
int x,y;
scanf("%d%d",&x,&y);
star_level[sum(x+1)]++;
change(x+1,1);
}
for(int i=0;i<n;i++)
printf("%d\n",star_level[i]);
return 0;
}


附录:

树状数组简介:

http://www.cnblogs.com/zhangshu/archive/2011/08/16/2141396.html

以及

http://www.cppblog.com/Ylemzy/articles/98322.html

都说的挺好
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm poj