您的位置:首页 > 其它

POJ 1284 Primitive Roots【欧拉函数】

2017-03-22 21:29 344 查看
题目来戳呀
Description
We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 
InputEach line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.OutputFor each p, print a single number that gives the number of primitive roots in a single line.Sample Input23
31
79
Sample Output10
8
24
题意:给出一个奇素数,求出它的原根的个数。
n的原根x满足条件0<x<n,并且有集合{ x^i mod n) | 1 <= i <=n-1 } 和集合{ 1, ..., n-1 }相等。
即x模n的阶等于φ(n),则称x为模n的一个原根。(其中φ(n)表示n的欧拉函数)
想法:看到某个题解说如果你知道欧拉函数这个题就不难了,那我可能看的是假的欧拉函数==原根的讲解
这一题主要用了以下定理:
1.一个数n有原根,那么它有φ(φ(n))个模n不同余的原根(n是否素数都可用)
2.所有的奇素数都是由原根的。
3.一个素数有原根,则有φ(n-1)个原根。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
int euler(int n)
{
int ans;
ans=n;
for(int i=2;i<=sqrt(n);++i)
{
if(n%i==0)
{
ans-=ans/i;
while(n%i==0)
n/=i;
}
}
if(n>1)
{
ans-=ans/n;
}
return ans;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
int m=euler(n-1);
printf("%d\n",m);
}
return 0;
}

ps:被某个欢脱的人拉去做他们队的翻译,感觉好阔怕orz吓得我都不敢上网找翻译了QAQ
很气,因为不能第一反应到是欧拉函数,结果某猪说是我题做得少不知道什么是原根TAT
现在看来就是考验知识储备量的。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: