您的位置:首页 > 其它

POJ 1284 Primitive Roots(欧拉函数)

2015-08-08 20:58 369 查看
Primitive Roots

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 3319Accepted: 1934
Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive
root modulo 7.

Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output

For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input
23
31
79

Sample Output
10
8
24


题目大意:

一个整数x(0 < x < p) 是奇素数p的原根,当且仅当集合{(x ^ i mod p)} | 1 <= i <= p -1|与集合{1,....,p-1}是相同的.例如,3的连续次幂对7取模的结果是3,2,6,4,5,1,所以3是7的一个原根.给出一个奇素数p(3 <= p < 65536),编程求出p的原根的个数.

解题思路:

本题应用到一个结论:m是素数,则m有p(m-1)个原根,其中p(n)是指不超过n且与n互素的正整数个数.

AC代码:

#include<iostream>

using namespace std;

int phi(int n)
{
int rea = n;
for(int i=2;i * i <= n;i++)
{
if(n % i == 0)
{
rea = rea - rea / i;
do
n /= i;
while(n % i == 0);
}
}
if(n > 1)
{
rea = rea - rea / n;
}
return rea;
}

int main()
{
int m;
while(scanf("%d",&m) != EOF && m)
{
int res = phi(m-1);
printf("%d\n",res);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: