您的位置:首页 > 其它

PAT_A 1027. Colors in Mars (20)

2017-03-04 10:42 357 查看

1027. Colors in Mars (20)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input

15 43 71

Sample Output

#123456

Sample Input

0 5 12

Sample Output

#00050C

Sample Input

0 5 13

Sample Output

#000510

分析:进制转化,ascll码

code:

#include<iostream>
using namespace std;
void output(int a)
{
char d[5];
int s=0;
while(a!=0)
{
switch(a%13)
{
case 10:
d[s++]='A';
break;
case 11:
d[s++]='B';
break;
case 12:
d[s++]='C';
break;
default:
d[s++]=a%13+'0';
}
a/=13;
}
if(s==0)
{
d[s++]='0';
d[s++]='0';
}else if(s==1)
d[s++]='0';
cout<<d[s-1]<<d[s-2];
}
int main()
{
int a,b,c;
cin>>a>>b>>c;
cout<<"#";
output(a);
output(b);
output(c);
cout<<endl;
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  进制转化 ascll