您的位置:首页 > 其它

HDU - 1757 - A Simple Math Problem ( 矩阵快速幂 )

2016-12-13 11:08 351 查看
Problem Description

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.

If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

 

Input

The problem contains mutiple test cases.Please process to the end of file.

In each case, there will be two lines.

In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )

In the second line , there are ten integers represent a0 ~ a9.

 

Output

For each case, output f(k) % m in one line.

 

Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

 

Sample Output

45
104

思路:和UVa的1087是一样的  题目链接

#include<cstdio>
#include<cstring>
#define LL long long
using namespace std;
int n,k,m;

struct Matrix{
LL m[10][10];
Matrix(){memset(m,0,sizeof(m));}
};

Matrix Mul(Matrix x ,Matrix y){
Matrix ans;
for(int i=0 ;i<10 ;i++){
for(int j=0 ;j<10 ;j++){
for(int k=0 ;k<10 ;k++){
ans.m[i][j] = ( ans.m[i][j] + x.m[i][k] * y.m[k][j] )%m;
}
}
}
return ans;
}

Matrix q_pow(Matrix x,int k){
Matrix ans;
for(int i=0 ;i<10 ;i++) ans.m[i][i]=1;

while(k){
if(k&1) ans = Mul(ans,x);
x = Mul(x,x);
k >>= 1;
}
return ans;
}

int main(){
LL a0,a1,a2,a3,a4,a5,a6,a7,a8,a9;
while(scanf("%d%d",&k,&m)!=EOF){
scanf("%lld%lld%lld%lld%lld%lld%lld%lld%lld%lld",&a0,&a1,&a2,&a3,&a4,&a5,&a6,&a7,&a8,&a9);
if(k<10){
printf("%d\n",k);
}else{
Matrix T ;
T.m[0][0] = a0;T.m[0][1] = a1;T.m[0][2] = a2;T.m[0][3] = a3;T.m[0][4] = a4;
T.m[0][5] = a5;T.m[0][6] = a6;T.m[0][7] = a7;T.m[0][8] = a8;T.m[0][9] = a9;

for(int i=1 ;i<10 ;i++) T.m[i][i-1]=1;

Matrix ans = q_pow(T,k-9);
LL res = 0;
for(int i=0 ;i<10 ;i++){
res = (res+ans.m[0][i]*(9-i))%m;
}
printf("%lld\n",res);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: