您的位置:首页 > 其它

POJ 3268 Silver Cow Party (Dijkstra_来回)

2016-11-05 20:28 399 查看
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X 

Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3


Sample Output

10


Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:最短路变形,n头母牛到达终点后又回到原处,他们走的都是最短路径,求哪头母牛走的路最多,输出长度。

可以分解成来/去,两种情况,因为是有向图,所以两边dijstra就可以了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int N =1000+10;
int c
,c2
,m

,vis
;
const int inf = 0x3f3f3f3f;
int main()
{
int n,e,s,i,j,u,v,Max;
while(cin>>n>>e>>s) {
for(i=1;i<=n;i++) {
for(j=1;j<=n;j++)
m[i][j]=inf;
c[i]=c2[i]=inf;
}
c[s]=c2[s]=0;
while(e--) {
cin>>u>>v;
cin>>m[u][v];
}
for(i=1;i<=n;i++) vis[i]=0;
while(1) {
u=-1;
Max=inf;
for(i=1;i<=n;i++) {
if(vis[i]==0&&c[i]<Max) {
u=i;
Max=c[i];
}
}
if(u==-1) break;
vis[u]=1;
for(v=1;v<=n;v++) {
c[v]=min(c[v],c[u]+m[u][v]);
}

}
for(i=1;i<=n;i++) vis[i]=0;
while(1) {
u=-1;
Max=inf;
for(i=1;i<=n;i++) {
if(vis[i]==0&&c2[i]<Max) {
u=i;
Max=c2[i];
}
}
if(u==-1) break;
vis[u]=1;
for(v=1;v<=n;v++) {
c2[v]=min(c2[v],c2[u]+m[v][u]);
}

}
Max=0;
for(i=1;i<=n;i++) Max=max(Max,c[i]+c2[i]);
printf("%d\n",Max);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: