您的位置:首页 > 理论基础 > 数据结构算法

poj 3268 Silver Cow Party【dijkstra】

2017-03-04 15:02 369 查看
Silver Cow Party

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 20681Accepted: 9464
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requires Ti (1 ≤Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X

Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

解题思路:进行两次最短路径, 一次正向一次方向,正向与反向相加即为来回的花费时间长。

# include <stdio.h>

# define INF 1000000
# define M 1005

int map[M][M];
int n, m, x;

void Dijkstra();

int main(void)
{
while (~scanf("%d %d %d", &n, &m, &x))
{
int i, j;
int a, b, t;
for (i = 1; i <= n; i++)
{
for (j = 1; j <= n; j++)
{
if (i == j)
{
map[i][j] = 0;
}
else
{
map[i][j] = INF;
}
}
}
for (i = 0; i < m; i++)
{
scanf("%d %d %d", &a, &b, &t);
map[b][a] = t;
}
Dijkstra();
}
return 0;
}

void Dijkstra()
{
int vis[M];
int dist[M];
int dback[M];
int i, j, v, min;
for (i = 1; i <= n; i++)
{
vis[i] = 0;
dist[i] = map[x][i];
}
for (i = 1; i <= n; i++)
{
min = INF;
for (j = 1; j <= n; j++)
{
if (!vis[j] && dist[j] < min)
{
min = dist[j];
v = j;
}
}
vis[v] = 1;
for (j = 1; j <= n; j++)
{
if (!vis[j] && map[v][j] + min < dist[j])
{
dist[j] = map[v][j] + min;
}
}
}

for (i = 1; i <= n; i++)
{
vis[i] = 0;
dback[i] = map[i][x];
}
for (i = 1; i <= n; i++)
{
min = INF;
for (j = 1; j <= n; j++)
{
if (!vis[j] && dback[j] < min)
{
min = dback[j];
v = j;
}
}
vis[v] = 1;
for (j = 1; j <= n; j++)
{
if (!vis[j] && map[j][v] + min < dback[j])
{
dback[j] = map[j][v] + min;
}
}
}
int max = -1;
for (i = 1; i <= n; i++)
{
if (dback[i] + dist[i] > max)
{
max = dback[i] + dist[i];
}
}
printf("%d\n", max);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息