您的位置:首页 > 其它

POJ 3268 Silver Cow Party (dijkstra来回最短路)

2015-03-23 21:43 447 查看
Silver Cow Party

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13576 Accepted: 6123
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X 

Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10


- - 思路非常经典的最短路题目  由于起点不一 但终点唯一

直接求终点出发的最短路并将边取反

回来的短路 其实就是原来的边 从终点出发求最短路

两个数组记录下 然后枚举即可

AC代码如下:

//
//  POJ 3268 Silver Cow Party
//
//  Created by TaoSama on 2015-03-20
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, m, s, dp[1005], dp2[1005];
struct Edge {
int to, cost;
};
vector<Edge> G
, Gr
;
typedef pair<int, int> Sta;

void dijkstra(vector<Edge> *G, int *dp) {
priority_queue<Sta, vector<Sta>, greater<Sta> > pq;
pq.push(Sta(0, s)); dp[s] = 0;
while(!pq.empty()) {
Sta p = pq.top(); pq.pop();
int u = p.second, d = p.first;
if(d > dp[u]) continue;
for(int i = 0; i < G[u].size(); ++i) {
Edge &e = G[u][i];
if(dp[e.to] > d + e.cost) {
dp[e.to] = d + e.cost;
//printf("dp[%d]: %d\n", e.to, dp[e.to]);
pq.push(Sta(dp[e.to], e.to));
}
}
}
}

int main() {
#ifdef LOCAL
freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
ios_base::sync_with_stdio(0);

scanf("%d%d%d", &n, &m, &s);
for(int i = 1; i <= m; ++i) {
int x, y, v; scanf("%d%d%d", &x, &y, &v);
G[x].push_back((Edge) {y, v});
Gr[y].push_back((Edge) {x, v});
}
memset(dp, 0x3f,sizeof dp);
memset(dp2, 0x3f,sizeof dp2);
dijkstra(G, dp); dijkstra(Gr, dp2);
int ans = -INF;
for(int i = 1; i <= n; ++i)
ans = max(ans, dp[i] + dp2[i]);
printf("%d\n", ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: