您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表六:有序链表的建立

2016-09-26 19:55 344 查看


数据结构实验之链表六:有序链表的建立

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。


Input

第一行输入整数个数N;

第二行输入N个无序的整数。


Output

依次输出有序链表的结点值。


Example Input

6
33 6 22 9 44 5



Example Output

5 6 9 22 33 44



#include <iostream>
#include <stdlib.h>
using namespace std;
typedef struct node
{
int data;
struct node *next;
}sq;
void pri(sq *head)
{
sq *p;
p=head->next;
while(p)
{
cout<<p->data;
p=p->next;
if(p)
cout<<" ";
else
cout<<endl;
}
}
int main()
{
int n,d;
sq *head,*tail,*p,*be;
cin>>n;
head=(sq *)malloc(sizeof(sq));
head->next=NULL;
for(int i=0;i<n;i++)
{
p=(sq *)malloc(sizeof(sq));
cin>>p->data;
if(i==0)
{
p->next=head->next;
head->next=p;
}
else
{
be=head;
tail=head->next;
while(tail)
{
if(p->data<tail->data)
{
be->next=p;
p->next=tail;
break;
}
else
{
be=tail;
tail=tail->next;
}
}
if(!tail)
{
p->next=NULL;
be->next=p;
}
}
}
pri(head);
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: