您的位置:首页 > 其它

HDU-2680 Choose the best route(SPFA)

2016-09-15 17:57 246 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13284    Accepted Submission(s): 4295


[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are
near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

[align=left]Input[/align]
There are several test cases. 

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

[align=left]Output[/align]
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

[align=left]Sample Output[/align]

1
-1

 

[align=left]Author[/align]
dandelion
 

[align=left]Source[/align]
2009浙江大学计算机研考复试(机试部分)——全真模拟

留个SPFA模板,因为起点有多个,所以将目的地当作起点,直接最短路

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;

const int N = 1005;
const int INF = 0x3f3f3f3f;

struct edge
{
int v,w;
};

int dis
;
bool vis
;
vector<edge> G
;
int n,m,s,d;

void Init()
{
for(int i = 0;i <= n;i++)
{
dis[i] = INF;
vis[i] = false;
G[i].clear();
}
}

void SPFA(int u)
{
dis[u] = 0;
vis[u] = true;
queue<int> q;
q.push(u);
while(!q.empty())
{
u = q.front();
vis[u] = false;
q.pop();
for(int i = 0;i < G[u].size();i++)
{
int v = G[u][i].v;
int w = G[u][i].w;
if(dis[v] > dis[u]+w)
{
dis[v] = dis[u]+w;
if(!vis[v])
{
vis[v] = true;
q.push(v);
}
}
}
}
}
int main()
{
while(~scanf("%d %d %d",&n, &m, &s))
{
Init();
int x,y,z;
edge tmp;
for(int i = 1;i <= m;i++)
{
scanf("%d %d %d",&x, &y, &z);
tmp.v = y;
tmp.w = z;
G[x].push_back(tmp);//单向
}

scanf("%d",&d);
int temp;
for(int i = 1;i <= d;i++)
{
scanf("%d",&temp);
tmp.v = temp;
tmp.w = 0;
G[0].push_back(tmp);
}
//printf("123\n");
SPFA(0);

if(dis[s] == INF)
printf("-1\n");
else
printf("%d\n",dis[s]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: