您的位置:首页 > 其它

HDU 2680 Choose the best route 【最短路 反向建图 dijkstra & SPFA 】

2015-08-17 20:17 555 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10335 Accepted Submission(s): 3333



[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s
home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

[align=left]Input[/align]
There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

[align=left]Output[/align]
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1


[align=left]Sample Output[/align]

1
-1


嗯,题目大意就是说,知道终点,但起点可以有好几个,问最短路,直接做或者floyed会超时,反向建图,把终点当起点就好了

#include <iostream>
#include<cstdio>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int n,map[1010][1010],vis[1010],rec[1010];
void dijkstra(int s)
{
memset(vis,0,sizeof(vis));
vis[s]=1;
for(int i=1;i<=n;++i)
rec[i]=map[s][i];
while(1)
{
int minw=inf,mark=0;
for(int i=1;i<=n;++i)
{
if(!vis[i]&&rec[i]<minw)
{
minw=rec[i];
mark=i;
}
}
if(!mark)
break;
vis[mark]=1;
for(int i=1;i<=n;++i)
{
if(!vis[i]&&rec[i]>rec[mark]+map[mark][i])
rec[i]=rec[mark]+map[mark][i];
}
}
}
int main()
{
int m,s,w,a,b,f,v[1010];
while(~scanf("%d%d%d",&n,&m,&s))
{
for(int i=0;i<=n;++i)
{
for(int j=0;j<=n;++j)
map[i][j]=inf;
}
while(m--)
{
scanf("%d%d%d",&a,&b,&f);
if(f<map[b][a])//不加这个判断会WA
map[b][a]=f;
}
scanf("%d",&w);
for(int i=0;i<w;++i)
scanf("%d",&v[i]);
dijkstra(s);
int min=inf;
for(int i=0;i<w;++i)
{
int tem=rec[v[i]];
min=min>tem?tem:min;
}
if(min==inf)
printf("-1\n");
else
printf("%d\n",min);
}
return 0;
}


嗯,当起点等于终点时输出-1而不是0,还有就是是单向的

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 1100
#define maxm 40000+40
#define inf 0x3f3f3f3f
using namespace std;
int n,m,s,w,cnt,head[maxn],rec[maxn];
struct node
{
int from,to,val,next;
};
node edge[maxm];
void initialize()
{
cnt=0;
memset(rec,0,sizeof(rec));
memset(head,-1,sizeof(head));
}
void add(int a,int b,int c)
{
node E={a,b,c,head[a]};
edge[cnt]=E;
head[a]=cnt++;
}
void getmap()
{
int a,b,c;
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
//add(a,b,c);
add(b,a,c);
}
scanf("%d",&w);
for(int i=0;i<w;++i)
scanf("%d",&rec[i]);
}
void spfa(int s)
{
queue<int>q;
int vis[maxn],dis[maxn];
memset(vis,0,sizeof(vis));
memset(dis,inf,sizeof(dis));
dis[s]=0;
vis[s]=1;
q.push(s);
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(dis[v]>dis[u]+edge[i].val)
{
dis[v]=dis[u]+edge[i].val;
if(!vis[v])
{
q.push(v);
vis[v]=1;
}
}
}
}
int minw=inf;
for(int i=0;i<w;++i)
{
if(rec[i]==s)
dis[rec[i]]=inf;
if(minw>dis[rec[i]])
minw=dis[rec[i]];
}
if(minw==inf)
printf("-1\n");
else
printf("%d\n",minw);
}
int main()
{
while(~scanf("%d%d%d",&n,&m,&s))
{
initialize();
getmap();
spfa(s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: