您的位置:首页 > 其它

hdu 2680 Choose the best route (最短路问题 dijkstra | spfa)

2017-09-11 23:41 531 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15464    Accepted Submission(s): 5010


Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take.
You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input

There are several test cases. 

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

Sample Output

1
-1

 

Author

dandelion
 

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟
 

Recommend

lcy

dijkstra   算法。。。

对边进行松弛。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define mem(a,x) memset(a,x,sizeof(a))
#define ll  long long
#define N 1005
#define inf 0x3f3f3f3f
using namespace std;
int maps

;
int vis
;
int dis
;
int n,m,s,e,Q;
void Dijkstra()
{
mem(vis,0);
for(int i=0; i<=n; i++)
dis[i]=maps[0][i];
vis[0]=1;
for(int j=0; j<=n; j++)
{
int Min=inf;
int Flag=0;
for(int i=0; i<=n; i++)
{
if(Min>dis[i]&&!vis[i])
{
Min=dis[i];
Flag=i;
}
}
vis[Flag]=1;
for(int i=0; i<=n; i++)
{
if(dis[Flag]+maps[Flag][i]<dis[i]&&!vis[i])
{
dis[i]=dis[Flag]+maps[Flag][i];
}
}
}
}
int main()
{
while(scanf("%d%d%d",&n,&m,&s)==3)
{
mem(maps,inf);
for(int i=0; i<=n; i++)maps[i][i]=0;
while(m--)
{
int Start,End,Cost;
scanf("%d%d%d",&Start,&End,&Cost);
if(maps[Start][End]>Cost)
maps[Start][End]=Cost;
}
scanf("%d",&Q);
while(Q--)
{
int Tmp_s;
scanf("%d",&Tmp_s);
maps[0][Tmp_s]=0;
}
Dijkstra();
if(dis[s]==inf)
printf("-1\n");
else
printf("%d\n",dis[s]);
}
}


spfa 对边进行松弛

#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#include<algorithm>
#define mem(a,x) memset(a,x,sizeof(a))
#define N 100000+5
#define inf 0x3f3f3f3f
using namespace std;

struct edage
{
    int to, cost;
};
int dis
;
int vis
;
int n,m,End;
vector<edage>v
;

void spfa(int u)
{
    mem(dis,inf);
    mem(vis,0);
    queue<int>q;
    q.push(u);
bc21

    dis[u]=0;
    vis[u]=1;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;

        for(int i = 0; i < v[u].size(); i++)
        {
            int to=v[u][i].to;
            int cost=v[u][i].cost;
            if(dis[to]>dis[u]+cost)
            {
                dis[to]=dis[u]+cost;
                if(!vis[to])
                {
                    vis[to]=1;
                    q.push(to);
                }
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d%d",&n,&m,&End))
    {
        int x,y,cost;
        for(int i=0;i<=n;i++)
        {
            v[i].clear();
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&cost);
            edage tmp;
            tmp.to=y;
            tmp.cost=cost;
            v[x].push_back(tmp);
        }
        scanf("%d",&m);
        while(m--)
        {
            int pos;
            scanf("%d",&pos);
            edage tmp;
            tmp.to=pos;
            tmp.cost=0;
            v[0].push_back(tmp);
        }
        spfa(0);
        if(dis[End]==inf)
            printf("-1\n");
        else
            printf("%d\n",dis[End]);
    }
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: