您的位置:首页 > 其它

树状数组 POJ 2352 Stars

2016-07-29 14:21 363 查看
题意:在坐标上有n个星星,如果某个星星坐标为(x, y), 它的左下位置为:(x0,y0),x0<=x 且y0<=y。如果左下位置有a个星星,就表示这个星星属于level x

按照y递增,如果y相同则x递增的顺序给出n个星星,求出所有level水平的数量。

题解:树状数组。处理i&-i时,注意i=0的情况。

代码:
因为输入是按照按照y递增,如果y相同则按x递增的顺序给出的。 所以,对于第i颗星星,它的level就是之前出现过的星星中,横坐标x小于等于i星横坐标的那些星星的总数量(前面的y一定比后面的y小)。

所以,用树状数组记录所有星星的x值,方便的求出所有值为0~x的星星总数量。

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int N=32005;
const int M=15005;
int bit
;
int du[M],hs[M];

void add(int i,int x)
{
while(i<N)
{
bit[i]+=x;
i+= i&-i;                             //////////////////////////////// i==0 时会引起死循环。
}
}

int sum(int i)
{
int s=0;
while(i>0)
{
s+=bit[i];
i-= i&-i;
}
return s;
}

int main()
{
int n;
while(~scanf("%d",&n))
{
memset(bit,0,sizeof(bit));
memset(du,0,sizeof(du));
memset(hs,0,sizeof(hs));
int x,y;
for(int i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
x++;                                     //////////////////////////////
du[i]=sum(x);
add(x,1);
}
for(int i=0;i<n;i++)
hs[du[i]]++;
for(int i=0;i<n;i++)
printf("%d\n",hs[i]);
}
return 0;
}





Stars

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 41474Accepted: 18079
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the
right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be
only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of
the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: