您的位置:首页 > 大数据 > 人工智能

hdoj1702ACboy needs your help again!

2016-07-25 21:03 337 查看
[align=left]Problem Description[/align]
ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

[align=left]Input[/align]
The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.
 

[align=left]Output[/align]
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

[align=left]Sample Input[/align]

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

[align=left]Sample Output[/align]

1
2
2
1
1
2
None
2
3

 
此题用队列和栈较为容易;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
#include<queue>
using namespace std;
int main()
{
int n;
char str1[20],str2[10];
scanf("%d",&n);
while(n--)
{
queue<int>que;
stack<int>st;
int m,x;
scanf("%d %s",&m,str1);
if(strcmp(str1,"FIFO")==0)
{
while(m--)
{
scanf("%s",str2);
if(strcmp(str2,"IN")==0)
{
scanf("%d",&x);
que.push(x);
}
else if(strcmp(str2,"OUT")==0)
{
if(!que.empty())
{
printf("%d\n",que.front());
que.pop();
}
else
printf("None\n");
}
}
}
if(strcmp(str1,"FILO")==0)
{
while(m--)
{
scanf("%s",str2);
if(strcmp(str2,"IN")==0)
{
scanf("%d",&x);
st.push(x);
}
else if(strcmp(str2,"OUT")==0)
{
if(!st.empty())
{
printf("%d\n",st.top());
st.pop();
}

else
printf("None\n");
}
}
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: