您的位置:首页 > 大数据 > 人工智能

hdoj1702ACboy needs your help again!(栈和队列基础题)

2016-07-25 17:35 302 查看
Description

ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4

4 FIFO

IN 1

IN 2

OUT

OUT

4 FILO

IN 1

IN 2

OUT

OUT

5 FIFO

IN 1

IN 2

OUT

OUT

OUT

5 FILO

IN 1

IN 2

OUT

IN 3

OUT

Sample Output

1

2

2

1

1

2

None

2
3

题意:给你n行,如果开头是IN 则输入并保存一个数,如果是OUT 判断前面输入的字符串是FIFO,就是先输入的数先输出,先进先出,如果是FILO,就是先进后出。如果数列里没有保存数,输出None。
思路:栈和队列的基本题,栈是先进后出,队列是先进先出。可以判断是FIFO还是FILO,然后选择用栈还是队列进行运算。注意:1,None而不是NONE,2对于每一个输入保存的数要记录有多少个(因为不记录的话输出有可能是上一次运算在栈或队列所保存下来的数)。这两处wa了好几次哎自己还需要多多努力。
代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<stack>
#include<queue>
#include<string.h>
using namespace std;
int main()
{
stack<int > sta;
queue<int > que;
int n;
scanf("%d",&n);
while(n--)
{
char g[10];
int t;
scanf("%d",&t);
char f[6];
int l1=0,l2=0;
memset(f,0,sizeof(f));
scanf("%s",f);
if(strcmp(f,"FIFO")==0)
{
for(int i=0;i<t;i++)
{
memset(g,0,sizeof(g));
scanf("%s",g);
if(strcmp(g,"IN")==0)
{
int h;
scanf("%d",&h);
que.push(h);
l1++;
}
else if(strcmp(g,"OUT")==0)
{
if(!que.empty()&&l1>0)
{
printf("%d\n",que.front());
que.pop();
l1--;
}
else if(que.empty()||l1<=0)
printf("None\n");
}
}
}
else if(strcmp(g,"OUT")==0)
{
while(t--)
{
memset(g,0,sizeof(g));
scanf("%s",g);
if(strcmp(g,"IN")==0)
{
int h;
scanf("%d",&h);
sta.push(h);
l2++;
}
else if(strcmp(g,"OUT")==0)
{
if(!sta.empty()&&l2>0)
{
printf("%d\n",sta.top());
sta.pop();
l2--;
}
else if(sta.empty()||l2<=0)
printf("None\n");
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: