您的位置:首页 > 其它

hdoj2199Can you solve this equation?

2016-07-27 18:56 302 查看
[align=left]Problem Description[/align]
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.
 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

[align=left]Output[/align]
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

[align=left]Sample Input[/align]

2
100
-4

 

[align=left]Sample Output[/align]

1.6152
No solution!

 
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
double fun(double x)
{
return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
double y,mid;
int n;
scanf("%d",&n);
while(n--)
{
scanf("%lf",&y);
if(y<6||y>fun(100))
printf("No solution!\n");
else
{
double l=1,r=100;
while(r-l>1e-8)
{
mid=(l+r)/2.0;
if(y>fun(mid))
{
l=mid;
}
else
{
r=mid;
}
}
printf("%.4lf\n",mid);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: