您的位置:首页 > 其它

Coins(poj1742)动态规划+挑战多重部分和问题

2016-07-19 10:26 369 查看
Language:
Default

Coins

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 34343 Accepted: 11661
Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change)
and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by
two zeros.
Output

For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4

Source

LouTiancheng@POJ

当时看题目时看到loutiancheng,停了一下,突然想起来楼教主(楼天城)。题目想了很久决定放弃,搜题解才发现这是传说中的男人八题╮(╯_╰)╭。题目和《挑战程序设计竞赛》中的“多重部分和问题”解法一样,只不过那一题是判断能否加成一个数,而这一题判断能加成1到m中多少个数。解法一样,附上博文“多重部分和问题”的链接多重部分和问题

AC代码如下:(跑了2s多,Time Limit 是3s。。。)

#include<iostream>
#include<cstring>
using namespace std;
int a[100005];
int c[1005];
int dp[100005];
int n,m;
void solve()
{
for(int i=0;i<n;i++){
for(int j=0;j<=m;j++){
if(dp[j]>=0) dp[j]=c[i];
else if(j<a[i]||dp[j-a[i]]<=0) dp[j]=-1;
else dp[j]=dp[j-a[i]]-1;
}
}
}
int main()
{
while(cin>>n>>m){
if(n==0&&m==0) break;
memset(dp,-1,sizeof(dp));
dp[0]=0;
for(int i=0;i<n;i++) cin>>a[i];
for(int i=0;i<n;i++) cin>>c[i];
int number=0;
solve();
for(int i=1;i<=m;i++){
if(dp[i]>=0) number++;
}
cout<<number<<endl;
}
return 0;
}


在搜到的题解中,学到了新姿势:

头文件#include<algorithm>中有count和count_if这两个函数。其中count函数是统计序列中某个关键字出现的次数,count_if函数是统计序列中与某个关键字匹配的次数。举例如下:

#include<iostream>
#include<algorithm>
using namespace std;
bool equal0(int x)
{
return x==0;
}
int main()
{
int a[]={0,1,-1,1,0,-1};
cout<<count(a,a+6,0)<<endl;
cout<<count_if(a,a+6,equal0)<<endl;
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息