您的位置:首页 > 其它

动态规划12之1017

2016-05-25 21:06 260 查看
1 题目编号:1017

2 题目内容:

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of
collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg>
</center><br>

 

Input

The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain
N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 
3 题意:01背包问题。给n个物品的价值和花费以及背包的容量,每个物品只有一件。问背包所放物品的最大价值

4 解题思路形成过程:用子问题定义状态:即dp[i][v]表示前i件物品恰放入一个容量为v的背包可以获得的最大价值。则其状态转移方程便是:dp[i][v]=max{dp[i-1[v],dp[i-1][v-cost[i]]+value[i]};需要注意体积为零的情况

5 代码:

#include<iostream>

using namespace std;

int dp[1000][1000];

int max(int x,int y)

{

    return x>y?x:y;

}

int main()

{

    int t,n,v,i,j;

    int va[1000],vo[1000];

    cin>>t;

    while(t--)

    {

        cin>>n>>v;

        for(i=1;i<=n;i++)

            cin>>va[i];

        for(i=1;i<=n;i++)

            cin>>vo[i];

        memset(dp,0,sizeof(dp));

         for(i=1;i<=n;i++)

        {

            for(j=0;j<=v;j++)

            {

                if(vo[i]<=j)

                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-vo[i]]+va[i]);

                else 

                    dp[i][j]=dp[i-1][j];

            }

        }

        cout<<dp
[v]<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划