您的位置:首页 > 编程语言 > Go语言

HDU 1397 Goldbach's Conjecture(素数判断)

2016-05-04 21:13 477 查看

Goldbach's Conjecture

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5692 Accepted Submission(s): 2204



[align=left]Problem Description[/align]
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of
all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2)
and (p2, p1) separately as two different pairs.

[align=left]Input[/align]
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

[align=left]Output[/align]
Each output line should contain an integer number. No other characters should appear in the output.

[align=left]Sample Input[/align]

6
10
12
0


[align=left]Sample Output[/align]

1
2
1


[align=left]Source[/align]
Asia 1998, Tokyo (Japan)

AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int s[65536]={0};
int main()
{
int i,j,ans;
for(i=2;i<=65535;i++)
{
for(j=2;j<=sqrt((double)i);j++)  //素数打表,不是素数的就是0
if(i%j==0)
break;
if(j>sqrt((double)i))
s[i]=i;
}
int n;
while(scanf("%d",&n)&&n)
{
for(ans=0,i=2;i<=n/2;i++)
{
if(s[i]!=0&&s[n-i]!=0) //判断顺向和逆向,比如10=7+3=3+7
ans++;
}
printf("%d\n",ans);
}
return 0;
}


AC:素数筛选
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
#define N 65536

int pri
;

int main()
{
int i,j,m,n,g,t,d,k;
int cnt,a,b,c;

memset(pri,0,sizeof(pri));

for(i=0;i<N;i++)
if(i%2)
pri[i] = 1;
pri[2] = 1;

for(i=3;i<=sqrt(N);i++)
if(pri[i])
{
for(j=i+i;j<N;j+=i)
pri[j] = 0;
}

while(cin>>n,n)
{
for(i=2,cnt=0;i<=n/2;i++)
{
if(pri[i]==0)
continue;
if(pri[n-i])
cnt++;
}

cout<<cnt<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: