您的位置:首页 > 大数据 > 人工智能

HDU.1022 Train Problem I【栈的简单应用】(3.14)

2016-03-14 20:54 489 查看


Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 29144 Accepted Submission(s): 11062



Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.







Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312


Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".
【代码如下】#include <iostream>
#include <stdio.h>
#include <stack>
#define max 100//宏定义  与int const max=100;不同,宏定义是定义一个数,const是定义一个固定变量
using namespace std;

int main()
{
stack<char>s;//很明显,这个题要用栈做
int n, i, j, k, result[max];//result用来记录是出栈还是入栈,进栈标记为1,出栈标记为0
char str1[max], str2[max];//两个字符串,用字符数组表示
while(cin>>n>>str1>>str2)//cin>>str可以用来输入字符数组,下次别说不会啦!
{
i=0, j=0, k=1;
s.push(str1[0]);//为了防止栈空,压一个进去(栈的题目应该都这样吧)
result[0] = 1;//记录进来了一个
while(i<n && j<n)
{
if(s.size() && s.top()==str2[j])//s.size表示用判断栈不为空,栈顶元素要与序列2的第一个字符一样,这是
{//如果栈顶元素和序列2当前元素相等,则弹栈,序列2集团向后移一位
j++;
s.pop();
result[k++] = 0;//第一个元素就可以出栈了,然后做k++
}
else
{//否则从序列1中取当前元素压入栈中
if(i==n) break;//如果全部都压进来了,还是弹不出去,就说明失败了
s.push(str1[++i]);//i<n,就压栈!
result[k++] = 1;
}
}
if(i==n)//如果i=n表示栈顶元素元素不等于序列2当前元素,且序列1中元素都已经入过栈,判断不能得到和序列2一样的答案
cout<<"No."<<endl;
else
{//输出入栈方式
cout<<"Yes."<<endl;
for(i=0; i<k; i++)
if(result[i])
cout<<"in"<<endl;
else
cout<<"out"<<endl;
}
cout<<"FINISH"<<endl;
}
return 0;
}
【分析】题解尽在代码中。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: