您的位置:首页 > 大数据 > 人工智能

hdoj 1702 ACboy needs your help again!(栈和队列的基础题)

2016-02-13 11:40 585 查看

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5034    Accepted Submission(s): 2605


[align=left]Problem Description[/align]
ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

[align=left]Input[/align]
The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.
 

[align=left]Output[/align]
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

[align=left]Sample Input[/align]

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

[align=left]Sample Output[/align]

1
2
2
1
1
2
None
2
3

 

[align=left]Source[/align]
2007省赛集训队练习赛(1)
 

[align=left]Recommend[/align]
lcy   |   We have carefully selected several similar problems for you:  1701 1700 1703 1704 1706 
栈和队列的基础题,队列先进先出,栈先进后出
#include<stdio.h>
#include<string.h>
int main()
{
int i,j,k,m,n,t,c[1100];
char a[110],b[110];
scanf("%d",&t);
while(t--)
{
scanf("%d%s",&m,a);
if(strcmp(a,"FIFO")==0)
{
i=j=0;
while(m--)
{
scanf("%s",b);
if(strcmp(b,"IN")==0)
{
scanf("%d",&n);
c[i++]=n;//进队列
}
else
{
if(j>=i)//判断队列是否为空
printf("None\n");
else
printf("%d\n",c[j++]);//出队列
}
}
}
else
{
i=0;
while(m--)
{
scanf("%s",b);
if(strcmp(b,"IN")==0)
{
scanf("%d",&n);
c[i++]=n;//进栈
}
else
{
if(i<1)
printf("None\n");
else
{
j++;
printf("%d\n",c[--i]);//出栈
}
}
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: