您的位置:首页 > 大数据 > 人工智能

virtual oj ACboy needs your help again!

2016-02-12 20:22 330 查看
ACboy needs your help again!

 
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

ACboy was kidnapped!! 

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. 

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy." 

The problems of the monster is shown on the wall: 

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 

and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input

The input contains multiple test cases. 

The first line has one integer,represent the number oftest cases. 

And the input of each subproblem are described above.
 

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

Sample Output

1
2
2
1
1
2
None
2
3
#include<stdio.h>
int main(){
int m,n,t,i,j,top,f,r;
char a[6];
int h[100];
char p[10];
scanf("%d",&t);
while(t--)
{
top=-1;
int cut=0;
scanf("%d",&m);
scanf("%s",p);
if(p[2]=='L'){  //栈
for(i=0;i<m;i++){
scanf("%s",a);
if(a[0]=='I')
scanf("%d",&h[++top]);
else{
if(top==-1) printf("None\n");
else{
printf("%d\n",h[top]);
top--;
cut++;
}
}
}
}
else{             //队列
for(i=0;i<m;i++){
scanf("%s",a);
if(a[0]=='I')
scanf("%d",&h[++top]);
else{
if(top==-1) printf("None\n");
else{
printf("%d\n",h[cut]);
cut++;
top--;
}
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm