您的位置:首页 > 大数据 > 人工智能

杭电1039 Easier Done Than Said?

2015-11-13 15:06 399 查看


Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10540    Accepted Submission(s): 5090


Problem Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them
and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

 

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

 

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

 

Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

 

Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

 

Source

Mid-Central USA 2000

 

Recommend

We have carefully selected several similar problems for you:  1062 1073 1043 1113 1075 

 

至少有一个元音字母。

不能有三个连续的元音字母或三个连续的辅音字母。

不能有两个连续的相同的字母,除了ee和oo

附代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[220];
int judge(char c)
{
if(c=='a'||c=='e'||c=='i'||c=='u'||c=='o')
return 1;
return 0;
}
int i,j,k,l,m,n,flag;
int main()
{
while(scanf("%s",s)&&strcmp(s,"end\0")!=0)
{
flag=1;
m=0;
l=strlen(s);
for(i=0;i<l;i++)
if(judge(s[i]))
m++;
if(m==0)
flag=0;
for(i=0;i<l-2;i++)
if((judge(s[i])&&judge(s[i+1])&&judge(s[i+2]))||(!judge(s[i])&&!judge(s[i+1])&&!judge(s[i+2])))
flag=0;
for(i=0;i<l-1;i++)
if(s[i]==s[i+1]&&(s[i]!='o'&&s[i]!='e'))
flag=0;
if(flag)
printf("<%s> is acceptable.\n",s);
else
printf("<%s> is not acceptable.\n",s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电