您的位置:首页 > 其它

杭电1075 What Are You Talking About

2015-11-13 22:07 309 查看


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 17882    Accepted Submission(s): 5823


Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

Output

In this problem, you have to output the translation of the history book.

 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

Sample Output

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

 

Author

Ignatius.L

 

Recommend

We have carefully selected several similar problems for you:  1251 1800 1671 1247 1298 

 

此题 不用map好像 无解,当然了,字典序肯定可以,附代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<iostream>
using namespace std;
map<string,string>word;
string ch,sh,help;
int i,j,k,l,m,n;
map<string,string> q;
int main()
{
q.clear();
j=0;
while(cin>>ch,ch!="START\0");
while(cin>>ch,ch!="END\0")
{
cin>>sh;
q[sh]=ch;
}
cin>>sh;
//gets(sh);
getchar();
char s[11000];
while(gets(s))
{
if(strcmp(s,"END\0")==0)
break;
char c[11000];
j=0;
int len=strlen(s);
for(i=0;i<len;i++)
{
if(s[i]>='a'&&s[i]<='z')
c[j++]=s[i];
else
{
c[j]='\0';
j=0;
help=c;
if(q.find(help)==q.end())
printf("%s",c);
else
cout<<q[c];
printf("%c",s[i]);
}
}
printf("\n");
}
return 0;
}

再附非map写的,不能ac的:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
char nm[15];
char nb[15];
}t[1100000];
char s[15000],c[15000],ch[15000],sh[15000];
int i,j,k,l,m,n,len,num;
int main()
{
j=0;
while(scanf("%s",ch),strcmp(ch,"START\0"));
while(scanf("%s",ch),strcmp(ch,"END\0"))
{
scanf("%s",t[num].nb);
strcpy(t[num++].nm,ch);
}
scanf("%s",ch);
while(gets(s))
{
if(strcmp(s,"END\0")==0)
break;
len=strlen(s);
j=0;
for(i=0;i<len;i++)
{
if(s[i]>='a'&&s[i]<='z')
c[j++]=s[i];
else
{
c[j]='\0';
j=0;
for(l=0;l<num;l++)
if(strcmp(t[l].nb,c)==0)
{
printf("%s",t[l].nm);
break;
}
if(l==num)
printf("%s",c);
printf("%c",s[i]);
}
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 模拟题