您的位置:首页 > 产品设计 > UI/UE

杭电2734 Quicksum

2015-11-17 17:28 471 查看


Quicksum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3021    Accepted Submission(s): 2232


Problem Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in
many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

 

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

 

Output

For each packet, output its Quicksum on a separate line in the output.

 

Sample Input

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#

 

Sample Output

46
650
4690
49
75
14
15

 

Source

Mid-Central USA 2006

 
简单题:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[11000];
int i,l;
int main()
{
while(gets(s))
{
if(strcmp(s,"#\0")==0)
break;
l=strlen(s);
for(i=0;i<l;i++)
{
if(s[i]==' ')
printf("%%20");
else if(s[i]=='!')
printf("%%21");
else if(s[i]=='$')
printf("%%24");
else if(s[i]=='%')
printf("%%25");
else if(s[i]=='(')
printf("%%28");
else if(s[i]==')')
printf("%%29");
else if(s[i]=='*')
printf("%%2a");
else printf("%c",s[i]);
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 简单题 字符串