您的位置:首页 > 其它

ZOJ 3712 Hard to Play

2015-09-06 13:32 267 查看
MightyHorse is playing a music game called osu!.



After playing for several months, MightyHorse discovered the way of calculating score in
osu!:

1. While playing osu!, player need to click some circles following the rhythm. Each time a player clicks, it will have three different points: 300, 100 and 50, deciding by how clicking timing fits the music.

2. Calculating the score is quite simple. Each time player clicks and gets
P points, the total score will add P, which should be calculated according to following formula:

P = Point * (Combo * 2 + 1)

Here Point is the point the player gets (300, 100 or 50) and Combo is the number of consecutive circles the player gets points previously - That means if the player doesn't miss any circle and clicks the
ith circle, Combo should be i - 1.

Recently MightyHorse meets a high-end osu! player. After watching his replay,
MightyHorse finds that the game is very hard to play. But he is more interested in another problem: What's the maximum and minimum total score a player can get if he only knows the number of 300, 100 and 50 points the player gets in one play?

As the high-end player plays so well, we can assume that he won't miss any circle while playing
osu!; Thus he can get at least 50 point for a circle.

Input

There are multiple test cases.

The first line of input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

For each test case, there is only one line contains three integers: A (0 ≤
A ≤ 500) - the number of 300 point he gets, B (0 ≤ B ≤ 500) - the number of 100 point he gets and
C (0 ≤ C ≤ 500) - the number of 50 point he gets.

Output

For each test case, output a line contains two integers, describing the minimum and maximum total score the player can get.

Sample Input

1
2 1 1


Sample Output

2050 3950


一共有三种数字300,100,50,每个样例中给出数字的个数,公式是P = Point * (Combo * 2 + 1),其中combo是这个数是第几个计算的,
结果中的两个,一个是从左到右计算,另一个是从又到左计算


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char a[3000008];
int main()
{
int a,b,c,s,i,j,k,t,l,sum;
cin>>t;
while(t--)
{
cin>>a>>b>>c;
l=a+b+c;
sum=0;
for(i=0;i<l;i++)
{
if(i<a)
{
sum+=300*(i*2+1);
}
else if(i<a+b)
{
sum+=100*(i*2+1);
}
else
sum+=50*(i*2+1);
}

cout<<sum<<" ";
sum=0;
for(i=0;i<l;i++)
{
if(i<c)
{
sum+=50*(i*2+1);
}
else if(i<c+b)
{
sum+=100*(i*2+1);
}
else
sum+=300*(i*2+1);
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: