您的位置:首页 > 编程语言 > Java开发

ZOJ 3714 Java Beans

2015-09-06 13:46 351 查看
There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select
M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from
M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and
M (1 ≤ M ≤ N). Here N and M are defined in above description. The second line of each test case contains
N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the
ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75


Sample Output

16
158


求连续M个数的最大和 环型

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
int T,n,m,a[10000];
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
a[n+i]=a[i];
}
int sum=0;
int s=0;
for(int i=1;i<=m;i++)sum+=a[i];
for(int i=m+1;i<n+m;i++)
{
s=max(sum,s);
sum=sum-a[i-m]+a[i];
}
s=max(sum,s);
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: