您的位置:首页 > 产品设计 > UI/UE

POJ-1503 Integer Inquiry-多个大数相加

2015-08-25 16:21 531 查看
Integer Inquiry
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 31808Accepted: 12404
Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

Source
East Central North America 1996

/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.      
*作    者:单昕昕    
*完成日期:2015年8月25日    
*版 本 号:v1.0        
*/ 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<algorithm>
using namespace std;
struct cal
{
    char s[100];
} c[100];
int main()
{
    int i,j=0,l,ll;
    int a[200],b[200];
    memset(a,0,sizeof(a));
    cin>>c[0].s;
    l=strlen(c[0].s);
    for(i=0; i<l; ++i)
        a[i]=c[0].s[l-i-1]-'0';
    ++j;
    while(cin>>c[j].s&& strcmp(c[j].s,"0"))
    {
        memset(b,0,sizeof(b));
        ll=strlen(c[j].s);
        for(i=0; i<ll; ++i)
            b[i]=c[j].s[ll-i-1]-'0';
        for(i=0; i<200; ++i)
        {
            a[i]+=b[i];
            while(a[i]>=10)
            {
                a[i+1]+=a[i]/10;
                a[i]%=10;
            }
        }
        ++j;
    }
    for(i=199; i>=0; --i)
        if(a[i]!=0)
            break;
    for(; i>=0; --i)
        cout<<a[i];
    cout<<endl;
    return 0;
}


一开始数据的长度控制的不好错了好久。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: