您的位置:首页 > 其它

【POJ1837】【最短路裸题】【建模】

2015-08-24 13:51 381 查看
Tram

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 12064Accepted: 4399
Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in
the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections
directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".
Sample Input
3 2 1
2 2 3
2 3 1
2 1 2

Sample Output
0

Source

Croatia OI 2002 Regional - Juniors

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int n,a,b;
const int maxn = 110;
int x[maxn];
int g[maxn][maxn];
bool ok[maxn];
int d[maxn];

int dij(int st,int e)
{
	for(int i=1;i<=n;i++)
	{
		d[i] = 0x3f3f3f3f;
		ok[i] =false;
	}

	d[st] = 0;
	for(int i=0;i<n-1;i++)
	{
		int mins = 0x3f3f3f3f;
		int p = -1;
		for(int j=1;j<=n;j++)
		{
			if(!ok[j] && d[j] < mins) 
			{
				mins = d[j];
				p = j;
			}
		}

		if(p == -1) break;
		ok[p] = true;

		for(int j=1;j<=n;j++)
		{
			if(!ok[j] && d[j] > d[p] + g[p][j])
			{
				d[j] = d[p] + g[p][j];
			}
		}
	}
	return d[e];
}

int main()
{
    while(scanf("%d%d%d",&n,&a,&b) != EOF)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(i == j) g[i][j] = 0;
				g[i][j] = 0x3f3f3f3f;
			}
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&x[i]);
			for(int k=1;k<=x[i];k++)
			{
				int v;
				scanf("%d",&v);
				if(k == 1)
				{
					g[i][v] = 0;
					continue;
				}
				g[i][v] = min(g[i][v],1);
			}
		}
		int ans = dij(a,b);
		if(ans == 0x3f3f3f3f)  ans = -1;
		printf("%d\n",ans);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: