您的位置:首页 > 其它

【POJ1308】【坑点过多】【并查集】

2015-08-25 14:52 302 查看
Language:
Default

Is It A Tree?

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 26041Accepted: 8893
Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997
[Submit] [Go Back] [Status]
[Discuss]


Home Page

Go
Back

To top

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

const int maxn = 100010;
int F[maxn];
bool in[maxn];
int find(int x)
{
	return F[x] == -1 ? x : F[x] = find(F[x]);
}
void merge(int x,int y)
{
	int fx = find(x);
	int fy = find(y);
	if(fx != fy)
	{
		F[fx] = fy;
	}
}
int main()
{
	int a,b;
	int C = 1;
	freopen("in.txt","r",stdin);
    while(scanf("%d%d",&a,&b))
	{
		int maxidx = 1;
		memset(F,-1,sizeof(F));
		memset(in,0,sizeof(in));
		if(a == -1 && b == -1) break;
		if(a == 0 && b == 0)
		{
			printf("Case %d is a tree.\n",C++);
			continue;
		}
		bool ok = true;
		if(a == b)
		{
			ok = false;
		}
		 else
		 {
			 merge(a,b);
		 }
		in[a] = in[b] = true;
		maxidx = max(maxidx,max(a,b));
		while(scanf("%d%d",&a,&b))
		{
			in[a] = in[b] = true;
			maxidx = max(maxidx,max(a,b));

			if(a == 0 && b == 0) break;
			if(!ok) continue;
			if(find(a) == find(b))
			{
				ok = false;
			}
			else
			{
				merge(a,b);
			}
		}
		bool conn;
		int cnt = 0;
		for(int i=1;i<=maxidx;i++)
		{
			if(in[i] && F[i] == -1) cnt ++;
		}
		conn = ((cnt == 1) ? true:false);
		if(ok && conn) printf("Case %d is a tree.\n",C++);
		else  printf("Case %d is not a tree.\n",C++);
 
		
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: