您的位置:首页 > 其它

【HDU3038】【加权并查集】

2015-08-25 09:55 477 查看


How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4027 Accepted Submission(s): 1541



Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).



Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo
this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the
answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why
asking trouble for himself~~Bad boy)



Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.



Output

A single line with a integer denotes how many answers are wrong.



Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1




Sample Output

1




Source

2009 Multi-University Training Contest 13 - Host
by HIT



Recommend

gaojie



#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int n,m;
const int maxn = 200010;
int F[maxn];
int d[maxn];

int find(int x)
{
	if(F[x] == -1) return x;
	int t = find(F[x]);
	d[x] += d[F[x]];
	return F[x] = t;
}
int main()
{
    while(scanf("%d%d",&n,&m) != EOF)
	{
		memset(F,-1,sizeof(F));
		memset(d,0,sizeof(d));
		int ans = 0;
		for(int i=0;i<m;i++)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			a--;
			int t1 = find(a);
			int t2 = find(b);
			if(t1 == t2)
			{
				if(d[b] - d[a] != c) ans++; 
			}
			else
			{
				F[t2] = t1;
				d[t2] = d[a] - (d[b] - c);

				//fa<-----a
				//     fb<-----b
			}
		}
		printf("%d\n",ans);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: