您的位置:首页 > 产品设计 > UI/UE

1005 hdoj Number Sequence (java函数格式)

2016-04-09 22:08 609 查看

Number Sequence

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 145944    Accepted Submission(s): 35462

[/align]

[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

 

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0

 

[align=left]Sample Output[/align]

2
5

 

[align=left]Author[/align]
CHEN, Shunbao
 

[align=left]Source[/align]
ZJCPC2004
 

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  1008 1004 1021 1019 1003

题目的意思很明白,就是给你表达式让你推出给的数,运用函数的递归,我把java函数温习了一遍,在敲了遍,希望有所提高。为了防止忘记留下函数语法知识java 函数

奉上新鲜出炉的代码
<pre name="code" class="java">import java.util.*;
import java.math.*;
import java.io.*;
public class Main {
public static int fun(int x,int y,int z)
{
if(z==1||z==2)
{
return 1;
}
else
{
z = (x * fun(x, y, z - 1) + y * fun(x, y, z - 2)) %7;//递归
return z;
}

}
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in = new Scanner(System.in);
while(in.hasNext())
{
int a,b,c;
a=in.nextInt();
b=in.nextInt();
c=in.nextInt();
if(a==0&&b==0&&c==0)
break;
else
{
System.out.println(fun(a,b,c%49));//防止超时%49和%7效果一样·,但%49不会超时
}
}

}

}



 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: