您的位置:首页 > 其它

POJ2051Argus【堆排序】

2015-08-19 11:48 288 查看
 

Language:
Default

Argus

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10192 Accepted: 4803
Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams
run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 

Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding
user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be
returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time,
they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input
Register 2004 200
Register 2005 300
#
5


Sample Output
2004
2005
2004
2004
2005


Source

Beijing 2004
题意给出几个id每个id每隔t时间出现一次输出前k个出现的id

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
struct Node{
int id;
int num;
int ans;
}Heap[1010];
char str[10];
bool cmp(Node a,Node b){
if(a.num==b.num)return a.id>b.id;
return a.num>b.num;
}
int main()
{
int i,size=0,k;
while(scanf("%s",str),str[0]!='#'){
size++;
scanf("%d%d",&Heap[size].id,&Heap[size].num);
Heap[size].ans=Heap[size].num;
push_heap(Heap+1,Heap+size+1,cmp);
}
scanf("%d",&k);
while(k--){
printf("%d\n",Heap[1].id);
Heap[1].num+=Heap[1].ans;
pop_heap(Heap+1,Heap+size+1,cmp);
push_heap(Heap+1,Heap+size+1,cmp);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ2051Argus堆排序