您的位置:首页 > 其它

POJ2151Check the difficulty of problems【概率dp求概率】

2015-08-24 18:00 246 查看
 
Check the difficulty of problems

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 5863

 

Accepted: 2556

Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 

1. All of the teams solve at least one problem. 

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you
calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range
of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0
Sample Output
0.972

 

题意:给出每个队做出每道题的概率求T个队每个队都做出至少一道题且冠军队做出N道题以上的概率

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
double pr[1010][35][35];//
double dp[1010][35];
double p[1010][35];
int main()
{
int M,T,N,i,j,k;
double p1,pN;
while(scanf("%d%d%d",&M,&T,&N),M||T||N){
memset(dp,0,sizeof(dp));
for(i=1;i<=T;++i){
for(j=1;j<=M;++j){
scanf("%lf",&p[i][j]);
}
}
memset(pr,0,sizeof(pr));
memset(dp,0,sizeof(dp));
p1=pN=1.0;
for(i=1;i<=T;++i){
pr[i][0][0]=1;
for(j=1;j<=M;++j){
pr[i][j][0]=pr[i][j-1][0]*(1.0-p[i][j]);
}
for(j=1;j<=M;++j){
for(k=1;k<=M;++k){
pr[i][j][k]=pr[i][j-1][k-1]*p[i][j]+pr[i][j-1][k]*(1-p[i][j]);//前j道题中做出k道题的概率
}
}
dp[i][0]=pr[i][M][0];
for(j=1;j<=M;++j){
dp[i][j]=dp[i][j-1]+pr[i][M][j];//做出j道题的概率
}
p1=p1*(dp[i][M]-dp[i][0]);//解决题数在1~M之间的概率
pN=pN*(dp[i][N-1]-dp[i][0]);//解决题数在1~N-1之间的概率 即没有队做出N道题以上的概率
}
printf("%.3lf\n",p1-pN);
}
return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ2151Check the dif