您的位置:首页 > 其它

hdoj4004The Frog's Games【二分】

2015-08-26 00:35 337 查看

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 4788    Accepted Submission(s): 2318


[align=left]Problem Description[/align]
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of
the riv

er is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 

are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

[align=left]Input[/align]
The input contains several cases. The first line of each case contains three positive integer L, n, and m. 

Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

[align=left]Output[/align]
For each case, output a integer standing for the frog's ability at least they should have.
 

[align=left]Sample Input[/align]

6 1 2
2
25 3 3
11
2
18

 

[align=left]Sample Output[/align]

4
11

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
int num[500010];
bool cmp(int a,int b){
return a<b;
}
bool judge(int l,int n,int m){
int i,j,ans=0;
for(i=0;i<=n;++i){
if(num[i]-ans>l)return false;
else{
for(j=i;j<=n;++j){
if(num[j]-ans>l)break;
}
i=j-1;ans=num[j-1];m--;
}
}
if(m>=0)
return true;
return false;
}
int main()
{
int i,j,n,m,l;
while(scanf("%d%d%d",&l,&n,&m)!=EOF){
for(i=0;i<n;++i){
scanf("%d",&num[i]);
}
sort(num,num+n,cmp);
int left=1,right=l;
num
=l;
while(left<=right){
int mid=(left+right)>>1;
if(judge(mid,n,m)){
right=mid-1;
}
else{
left=mid+1;
}
}
printf("%d\n",left);
}
return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj4004The Frogs Ga