您的位置:首页 > 大数据 > 人工智能

多校3 1004 Painter

2015-07-29 08:17 369 查看

Painter

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 497 Accepted Submission(s): 239


[align=left]Problem Description[/align]
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.

[align=left]Input[/align]
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.

[align=left]Output[/align]
Output an integer as described in the problem description.

[align=left]Sample Input[/align]

2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR

[align=left]Sample Output[/align]

3
6

[align=left]Source[/align]
2015 Multi-University Training Contest 3

[align=left]Recommend[/align]
wange2014 | We have carefully selected several similar problems for you: 5325 5324 5323 5322 5321

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
int T;
int n;
int i,j,k;
char a[55][56];
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s",a[i]);
}
int l=strlen(a[0]);

int ans=0,x,y,flg;
for(i=0;i<l;i++)
{
flg=0;
x=0,y=i;
while(x<n && y<l)
{
if(a[x][y]=='R' || a[x][y]=='G')
{
if(flg==0)
ans++,flg=1;
}
else
{
flg=0;
}
x++,y++;
}
}
//printf("%d\n",ans);

for(i=1;i<l;i++)
{
flg=0;
x=n-1,y=i;
while(x>=0 && y<l)
{
if(a[x][y]=='B' || a[x][y]=='G')
{
if(flg==0)
ans++,flg=1;
}
else
{
flg=0;
}
x--,y++;
}
}
//printf("%d\n",ans);

for(j=1;j<n;j++)
{
flg=0;
x=j,y=0;
while(x<n && y<l)
{
if(a[x][y]=='R' || a[x][y]=='G')
{
if(flg==0)
ans++,flg=1;
}
else
{
flg=0;
}
x++,y++;
}
}
//printf("%d\n",ans);

for(j=0;j<n;j++)
{
flg=0;
x=j,y=0;
while(x>=0 && y<l)
{
if(a[x][y]=='B' || a[x][y]=='G')
{
if(flg==0)
ans++,flg=1;
}
else
{
flg=0;
}
x--,y++;
}
}
printf("%d\n",ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: