您的位置:首页 > 大数据 > 人工智能

HDU 1532 基础EK Drainage Ditches

2015-07-27 10:39 543 查看

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11744 Accepted Submission(s): 5519


[align=left]Problem Description[/align]
Every
time it rains on Farmer John's fields, a pond forms over Bessie's
favorite clover patch. This means that the clover is covered by water
for awhile and takes quite a long time to regrow. Thus, Farmer John has
built a set of drainage ditches so that Bessie's clover patch is never
covered in water. Instead, the water is drained to a nearby stream.
Being an ace engineer, Farmer John has also installed regulators at the
beginning of each ditch, so he can control at what rate water flows into
that ditch.
Farmer John knows not only how many gallons of water
each ditch can transport per minute but also the exact layout of the
ditches, which feed out of the pond and into each other and stream in a
potentially complex network.
Given all this information, determine
the maximum rate at which water can be transported out of the pond and
into the stream. For any given ditch, water flows in only one direction,
but there might be a way that water can flow in a circle.

[align=left]Input[/align]
The
input includes several cases. For each case, the first line contains
two space-separated integers, N (0 <= N <= 200) and M (2 <= M
<= 200). N is the number of ditches that Farmer John has dug. M is
the number of intersections points for those ditches. Intersection 1 is
the pond. Intersection point M is the stream. Each of the following N
lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei
<= M) designate the intersections between which this ditch flows.
Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <=
10,000,000) is the maximum rate at which water will flow through the
ditch.

[align=left]Output[/align]
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

[align=left]Sample Input[/align]

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

[align=left]Sample Output[/align]

50

[align=left]Source[/align]
USACO 93

[align=left]Recommend[/align]
lwg | We have carefully selected several similar problems for you: 1533 3338 1569 3572 3416

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int dp[400][400],pre[400];
const int tmin=999999999;
int maxflow;
void EK(int start,int end,int n){
while(1){
queue<int>q;
q.push(1);
int  minflow=tmin;
memset(pre,0,sizeof(pre));
while(!q.empty()){
int u=q.front();
q.pop();
for(int i=1;i<=n;i++){
if(dp[u][i]>0&&!pre[i]){
pre[i]=u;
q.push(i);
}
}
}
if(pre[end]==0)
break;
for(int i=end;i!=start;i=pre[i]){
minflow=min(dp[pre[i]][i],minflow);
}
for(int i=end;i!=start;i=pre[i]){
dp[pre[i]][i]-=minflow;
dp[i][pre[i]]+=minflow;
}
maxflow+=minflow;
}
}
int main(){

int n,m;
while(scanf("%d%d",&m,&n)!=EOF){
memset(dp,0,sizeof(dp));
memset(pre,0,sizeof(pre));
int u,v,w;
for(int i=1;i<=m;i++){
scanf("%d%d%d",&u,&v,&w);
dp[u][v]+=w;
}
maxflow=0;
EK(1,n,n);
printf("%d\n",maxflow);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: