您的位置:首页 > 大数据 > 人工智能

Fibonacci Again

2015-07-27 08:33 471 查看


Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 44035 Accepted Submission(s): 21020



Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no


http://acm.hdu.edu.cn/showproblem.php?pid=1021

先打出前50个的数的答案发现他有一种规律,要推得话也是可以的,7%3=1,11%3=2,那么(7+11)%3一定是0,后面余数分别是2,2,1,0,1,1,2,0.。。。。。。

so代码如下:

#include <cstdio>
int main()
{
int n;
while(scanf("%d",&n)!=EOF){
if(n==0||n==1)printf("no\n");
else if(n%4==2)printf("yes\n");
else printf("no\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: