您的位置:首页 > 其它

暑假集训第二周——贪心 盒子平移

2015-07-21 20:41 267 查看
H - 盒子平移
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a
real wall.", she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number
of bricks moved. Can you help? 



Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100. 

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 

Output

For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.

Sample Input

6
5 2 4 1 7 5
0


Sample Output

Set #1
The minimum number of moves is 5.


分析

一堆积木。每次移动一个积木到另外一个积木上,问最少多少步可以让他们高度一致。

最少的步数求法为:用每一个积木减去平均值,取绝对值相加之后除以2.

但是我是用的一种比较直观的思路,就是把所有积木排序,然后处理最大的和最小的,

接着排序处理,直到最后一个为平均数。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int n,a[101],i,t,j=1,k;
while(scanf("%d",&n)&&n!=0)
{
k=0;
for(i=0; i<n; i++)
{
scanf("%d",&a[i]);
k+=a[i];
}
k=k/n;
sort(a,a+n);
printf("Set #%d\nThe minimum number of moves is ",j++);
t=0;
while(a[n-1]>k)
{
if(a[n-1]-k>k-a[0])
{
t+=k-a[0];
a[n-1]-=k-a[0];
a[0]=k;
}
else
{
t+=a[n-1]-k;
a[n-1]=k;
a[0]+=a[n-1]-k;
}
sort(a,a+n);
}
printf("%d.\n\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  排序