您的位置:首页 > 其它

暑假集训第二周——贪心 F - 削木棒

2015-07-21 21:01 260 查看
F - 削木棒
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be
2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case,
and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1


Sample Output

2
1
3


分析

两大主要问题,第一结构体排序,第二对数据进行处理,用两个for循环处理完所有数据,找到最优解

处理完一个数据后把它标记为0,减少循环次数

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct  M
{
int l,w;
} a[5001];
int cmp(M a,M b)
{
if(a.l==b.l)
return a.w<b.w;
else
return a.l<b.l;
}
int main()
{
int n,m,i,j,t;
scanf("%d",&n);
while(n--)
{
int s=0;
scanf("%d",&m);
for(i=0; i<m; i++)
scanf("%d %d",&a[i].l,&a[i].w);
sort(a,a+m,cmp);
for(i=0; i<m; i++)
{
t=a[i].w;
if(a[i].w!=0)
{
for(j=i+1; j<m; j++)
if(a[j].w>=t)
{
t=a[j].w;
a[j].w=0;

}
s++;
}
}
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  排序 标记