您的位置:首页 > 其它

poj 1573 Robot Motion

2015-06-08 11:55 260 查看
Robot Motion

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11209Accepted: 5462
Description



A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source

Mid-Central USA 1999

给出每个点机器人的走的方向,问什么时候出界或者圈。。

居然(s)。。。。。。。。

简单模拟

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <math.h>
#include <vector>
#include <stdlib.h>
using namespace std;
char mp[233][233];
int mpp[233][233];
int n,m,x;
void dfs(int x,int y)
{
int xx,yy;
if(mp[x][y]=='N')
{
xx=x;
yy=y-1;
}
else if(mp[x][y]=='S')
{
xx=x;
yy=y+1;
}
else if(mp[x][y]=='W')
{
xx=x-1;
yy=y;
}
else
{
xx=x+1;
yy=y;
}
if(xx<=0||xx>m||yy<=0||yy>n)
{
cout<<mpp[x][y]<<" step";
cout<<"(s)";
cout<<" to exit"<<endl;
return ;
}
if(mpp[xx][yy])
{
cout<<mpp[xx][yy]-1;
cout<<" step";cout<<"(s)";
cout<<" before a loop of "<<mpp[x][y]-mpp[xx][yy]+1<<" step";if(mpp[x][y]-mpp[xx][yy]!=0)cout<<"(s)"<<endl;
return ;
}
mpp[xx][yy]=mpp[x][y]+1;
dfs(xx,yy);
}
int main()
{
while(cin>>n>>m>>x)
{
if(n==0&&m==0&&x==0) break;
memset(mpp,0,sizeof(mpp));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
cin>>mp[j][i];
}
}
mpp[x][1]=1;
dfs(x,1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: