您的位置:首页 > 理论基础 > 计算机网络

poj 1459 Power Network 网络流

2015-06-18 20:17 681 查看
Power Network

Time Limit: 2000MSMemory Limit: 32768K
Total Submissions: 24593Accepted: 12825
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount
0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power
transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of
Con.



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set
ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can
occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second
data set encodes the network from figure 1.
Source

Southeastern Europe 2003

应该算网络流最大流的裸题了吧,建一个汇点和一个源点。跑一下sap或者dinic呗

应该会总结一篇关于dinic和sap 的文章,先拖着。。【好像还拖着什么呢吧。。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <stack>
#include <math.h>
#include <queue>
#include <map>
#include <set>
#include <stdlib.h>
#include <vector>
using namespace std;
#define maxn 20010
const int N = 5005;
const int M = 30005;
int np,nc;
struct Enode{
int y, c, next;
} e[M * 2];
struct Point
{
int son,cur,pre,lim,d;
} a[maxn];
int n, m, tot, head
, now
, h
, vh
, augc, found, flow;
int st, ed, cnt[maxn];
void Addedge(int x, int y, int c){
e[++tot].y = y; e[tot].c = c; e[tot].next = head[x]; head[x] = tot;
e[++tot].y = x; e[tot].c = 0; e[tot].next = head[y]; head[y] = tot;
}
void Init(){
int x, y, c, i;
tot = -1; memset(head, -1, sizeof(head));
char c1,c2,c3;
for (i = 0; i < m; i++)
{
cin>>c1>>x>>c2>>y>>c3>>c;
x+=2;
y+=2;
Addedge(x, y, c);
}
for(i=1;i<=np;i++)
{
cin>>c1>>x>>c2>>c;
x+=2;
Addedge(1,x,c);
}
for(i=1;i<=nc;i++)
{
cin>>c1>>x>>c2>>c;
x+=2;
Addedge(x,n,c);
}
memcpy(now, head, sizeof(head));
}

void Aug(int x, int st, int ed, int n){
int p = now[x], minh = n - 1, augco = augc;
if (x == ed){
found = 1;
flow += augc;
return;
}
while (p != -1){
if (e[p].c > 0 && h[e[p].y] + 1 == h[x]){
augc = min(augc, e[p].c);
Aug(e[p].y, st, ed, n);
if (h[st] >= n) return;
if (found) break;
augc = augco;
}
p = e[p].next;
}
if (found){
e[p].c -= augc;
e[p ^ 1].c += augc;
}else{
p = head[x];
while (p != -1){
if (e[p].c > 0 && h[e[p].y] < minh){
minh = h[e[p].y];
now[x] = p;
}
p = e[p].next;
}
vh[h[x]] --;
if (!vh[h[x]]) h[st] = n;
h[x] = minh + 1;
vh[h[x]] ++;
}
}
void Maxflow(int st, int ed, int n){
flow = 0;
memset(h, 0, sizeof(h));
memset(vh, 0, sizeof(vh));
vh[0] = n;
while (h[st] < n){
found = 0;
augc = 1 << 30;
Aug(st, st, ed, n);
}
}
int main()
{
while(cin>>n>>np>>nc>>m)
{
n+=2;
Init();
Maxflow(1, n, n);
printf("%d\n", flow);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: