您的位置:首页 > 产品设计 > UI/UE

poj 3080 Blue Jeans

2015-06-20 15:37 267 查看
Blue Jeans

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13725Accepted: 6100
Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences
of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output
no significant commonalities
AGATAC
CATCATCAT

Source

South Central USA 2006

求最大连续公共子序列

暴力

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <string.h>
#include <vector>
#include <stdlib.h>
#include <math.h>
using namespace std;
int n;
#define len 60
int main()
{
int test;
cin>>test;
for(int i=1;i<=test;i++)
{
cin>>n;
char ** DNA = new char *
;
for(int p=0;p<n;p++)
{
DNA[p]=new char[61];
cin>>DNA[p];
}
char obj[233];
int strlen = 0;
int length = 1;
for(int i=0;;i++)
{
char dna[233];
int pi=i;
if(pi+length>len)
{
length++;
i=-1;
if(length>len)
break;
continue;
}
for(int j=0;j<length;j++)
{
dna[j]=DNA[0][pi++];
}
dna[length]='\0';
bool flag =true;
for(int k=1;k<n;k++)
{
if(!strstr(DNA[k],dna))
{
flag=false;
break;
}
}
if(flag)
{
if(strlen<length)
{
strlen = length;
strcpy (obj,dna);
}
else if(strlen==length)
{
if(strcmp(obj,dna)>0)
strcpy (obj,dna);

}
}
}
if(strlen<3)
{

cout<<"no significant commonalities"<<endl;
}
else cout<<obj<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: