您的位置:首页 > 其它

hdu 3371 Connect the Cities(最小生成树kruskal)

2015-04-08 20:20 447 查看

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12309 Accepted Submission(s): 3403



Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities
again, but they don’t want to take too much money.


Input
The first line contains the number of test cases.

Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.

To make it easy, the cities are signed from 1 to n.

Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.

Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.



Output
For each case, output the least money you need to take, if it’s impossible, just output -1.


Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6




Sample Output
1




Author
dandelion


Source
HDOJ Monthly Contest – 2010.04.04
题目分析:用并查集先将能过在一起的点缩点,然后套最小生成树模板即可

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
#define MAX 507

using namespace std;

int n,m,k,t,q;

struct Edge
{
    int u,v,w;
    bool operator < ( const Edge& a ) const 
    {
        return w < a.w;
    }
}e[MAX*MAX];

int cc = 0;

void add ( int u , int v , int w )
{
    e[cc].u = u;
    e[cc].v = v;
    e[cc].w = w;
    cc++;
}

int fa[MAX];

void init ( )
{
    for ( int i = 1 ; i <= n ; i++ )
        fa[i] =i;
    cc = 0;
}

int find ( int x )
{
    return x==fa[x]?x:fa[x]=find(fa[x]);
}

void _union ( int x , int y )
{
    x = find (x);
    y = find (y);
    fa[x] = y;
}

int kruskal ( )
{
    sort ( e , e+cc );
    int sum = 0;
    for ( int i = 0 ; i < m ; i++ )
    {
        int u = find ( e[i].u );
        int v = find ( e[i].v );
        if ( u == v ) continue;
        _union ( u , v );
        sum += e[i].w;
    }
    int flag = find ( 1 );
    for ( int i = 2 ; i <= n ; i ++ )
        if ( find(i) != flag ) return -1;
    return sum;
}

int main ( )
{
    int u , v , w;
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%d%d%d" , &n , &m , &k );
        init();
        for ( int i = 0 ; i < m ; i++ )
        {
            scanf ( "%d%d%d" , &u , &v , &w );
            add ( u , v , w );
        }
        for ( int i = 0 ; i < k ; i++ )
        {
            scanf ( "%d" , &q );
            scanf ( "%d" , &u );
            for ( int j = 1 ; j < q ; j++ )
            {
                scanf ( "%d" , &v );
                _union ( u , v );
            } 
        }
        printf ( "%d\n" , kruskal ( ) );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: