您的位置:首页 > 其它

HDU 3371 Connect the Cities 最小生成树

2014-09-25 17:08 375 查看

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10454 Accepted Submission(s): 2967



Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities
again, but they don’t want to take too much money.


Input
The first line contains the number of test cases.

Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.

To make it easy, the cities are signed from 1 to n.

Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.

Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.



Output
For each case, output the least money you need to take, if it’s impossible, just output -1.



Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6




Sample Output
1


/*
HDOJ 3371 最小生成树 
*/

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;

struct node{
    
    int x,y,dis;
};
node e[25001];

int pre[501];

int cmp(node a,node b)
{
    return a.dis<b.dis;
}

int find(int x)
{
    if(x!=pre[x])
        return pre[x]=find(pre[x]);
    return pre[x];
}

int main()
{
    int n,i,j,sum,m,x,y,a,b,k,t,v,kk;
    
    //freopen("test.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        
        for(i=1;i<=n;i++)
            pre[i]=i;
            
        kk=0;
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&v);
            e[kk].x=a;
            e[kk].y=b;
            e[kk].dis=v;
            kk++;        
        }
        for(i=0;i<k;i++)
        {
            scanf("%d",&v);
            scanf("%d",&a);
            v--;
            while(v--)
            {
                scanf("%d",&b);
                x=find(a);
                y=find(b);
                if(x!=y)
                {
                    pre[x]=y;
                }
            }        
        }
        
        sort(e,e+kk,cmp);

        sum=0;
        for(i=0;i<kk;i++)
        {
            x=find(e[i].x);
            y=find(e[i].y);
            if(x!=y)
            {
                sum+=e[i].dis;
                pre[x]=y;
            }
        }
        
        k=0;
        for(i=1;i<=n;i++)
            if(pre[i]==i)
                k++;
        if(k==1)
            printf("%d\n",sum);
        else
            printf("-1\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: