您的位置:首页 > 大数据 > 人工智能

HDU 1021 Fibonacci Again

2015-03-10 16:59 351 查看
Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no
题意:对于输入的数字。计算f
是否能整除3;这道题的数据如果按照正常的方法计算,会特别大,所以需要一边计算一边处理数据。思路:如果f[i]%3==0则在下一次的f[i+1]=f[i-1]+f[i]中,f[i]可以变为0;just soso。。。


#include<stdio.h>
#define N 1000000
int f[N];
int main()
{
int n,i;
f[0]=7;
f[1]=11;
while(scanf("%d",&n)!=EOF)
{
for(i=2;i<=n;i++)
{
f[i]=f[i-1]+f[i-2];
if(f[i]%3==0)  
f[i]=0;
else
f[i]=f[i]%3;
}
if(f[n]%3==0)
{
printf("yes\n");
}
else
{
printf("no\n");
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: