您的位置:首页 > 大数据 > 人工智能

hdu 1021 Fibonacci Again【找规律】

2015-12-17 20:11 399 查看

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 47362 Accepted Submission(s): 22517

[align=left]Problem Description[/align]
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

[align=left]Input[/align]
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

[align=left]Output[/align]
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

[align=left]Sample Input[/align]

0
1
2
3
4
5

[align=left]Sample Output[/align]

no
no
yes
no
no
no

不难发现,从第三个数开始,每四次循环一次 0...

因为基数是 7+11 =18 ,18%3==0所以来回累加的话,一定呈现规律性的变化....

#include<stdio.h>
int main()
{
int n;
while(~scanf("%d",&n))
{
if((n-2)%4==0)
{
printf("yes\n");
}
else
{
printf("no\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: