您的位置:首页 > 理论基础 > 数据结构算法

【Jason's_ACM_解题报告】Tree

2015-02-17 11:18 281 查看

Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated
with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have
more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.


Sample Input 


3 2 1 4 5 7 6

3 1 2 5 6 7 4

7 8 11 3 5 16 12 18

8 3 11 7 16 18 12 5

255

255

Sample Output 

1

3

255

此题锻炼二叉树的递归遍历与递归构造,采用以数组模拟指针的方法实现。是纯粹的算法题,已知中序遍历序列和前序或者后序遍历可以构造出一棵二叉树。

附代码如下:
#include<cstdio>
#include<string>
#include<sstream>
#include<iostream>

using namespace std;

#define MAXN (10000)
#define OO (100000000)

int in_order[MAXN],post_order[MAXN],lc[MAXN],rc[MAXN];
int n;

bool input(int* a){
string line;
if(!getline(cin,line))return false;
stringstream ss(line);
int x;
n=0;
while(ss>>x) a[n++]=x;
return true;
}

int build(int L1,int R1,int L2,int R2){
if(L1>R1)return 0;
int node=post_order[R2];
int i=L1;
while(node!=in_order[i])i++;
lc[node]=build(L1,i-1,L2,L2+i-1-L1);
rc[node]=build(i+1,R1,L2+i-L1,R2-1);
return node;
}

int best,best_sum;

void dfs(int node,int sum){
sum+=node;
if(!lc[node]&&!rc[node]){
if(sum<best_sum||(sum==best_sum&&node<best)){best=node;best_sum=sum;}
}
if(lc[node])dfs(lc[node],sum);
if(rc[node])dfs(rc[node],sum);
}

int main(){
while(input(in_order)){
input(post_order);
build(0,n-1,0,n-1);
best_sum=OO;
dfs(post_order[n-1],0);
printf("%d\n",best);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息